We use cookies to ensure that we give you the best experience on our website.  Visit our Privacy Policy to learn more. If you continue to use this site, we will assume that you are okay with it.

Your choices regarding cookies on this site.
Your preferences have been updated.
In order for the changes to take effect completely please clear your browser cookies and cache. Then reload the page.

Werk #10447: agent_kubernetes: use new API versions

ComponentChecks & Agents
Titleagent_kubernetes: use new API versions
Date2019-10-28 13:34:30
Checkmk EditionCheckmk Raw Edition (CRE)
Checkmk Version1.6.0p6,1.7.0i1
LevelTrivial Change
ClassBug Fix
CompatibilityIncompatible - Manual interaction might be required

The Kubernetes release 1.16 deprecated two API endpoints. To honor these deprecations the agent_kubernetes now uses the recommended new API endpoints by default. All Kubernetes versions since 1.9 support these new API endpoints.

To grant Checkmk access to the new API endpoints an updated version of the check_mk_rbac.yaml has to be applied.

If you have a Kubernetes version >= 1.16 and use a special agent prior to this werk a NotFound (404) error will be returned.

If you do not apply the updated check_mk_rbac.yaml the special agent will fall back to the old API version to be backwards compatible.