Werk #13904: Update vulnerable Python dependencies

Komponente Core & setup
Titel Update vulnerable Python dependencies
Datum 01.06.2022
Checkmk-Editon Checkmk Raw (CRE)
Checkmk-Version 2.2.0i1 2.1.0p4 2.0.0p27
Level Kleine Änderung
Klasse Sicherheitsfix
Kompatibilität Kompatibel - benötigt kein manuelles Eingreifen

Update numpy, pillow, pyjwt, rsa and Werkzeug to fix these CVEs:

  • CVE-2021-41495
  • CVE-2021-41496
  • CVE-2021-34141
  • CVE-2022-30595
  • CVE-2022-29217
  • CVE-2020-25658
  • CVE-2022-29361
  • Zur Liste aller Werks