Catch up on the latest product updates, best practices, and expert insights from the Checkmk Conference #12 – Watch the livestream recordings now

Werk #18144: Fix error in displaying error if site user is not allowed to use crontab

Component Site management
Title Fix error in displaying error if site user is not allowed to use crontab
Date Jun 16, 2025
Level Trivial Change
Class Bug Fix
Compatibility Compatible - no manual interaction needed
Checkmk versions & editions
2.5.0b1 Checkmk Community, Checkmk Pro, Checkmk Ultimate, Checkmk Cloud, Checkmk Ultimate MT
2.4.0p7 Checkmk Community, Checkmk Pro, Checkmk Ultimate, Checkmk Cloud, Checkmk Ultimate MT

Previously, the omd service crontab would raise an exception, if the site user did not have access to crontab.

Starting crontab...You (site2) are not allowed to use this program (crontab)
See crontab(1) for more information
Exception ignored in: <_io.TextIOWrapper name='<stdout>' mode='w' encoding='utf-8'>
BrokenPipeError: [Errno 32] Broken pipe
failed

This exception was harmless, but has been fixed nonetheless. The new output looks like this:

Starting crontab...You (site2) are not allowed to use this program (crontab)
See crontab(1) for more information
failed

To the list of all Werks