Werk #12755: Fix AssertionError if escalation is used in flexible notifications

Component Notifications
Title Fix AssertionError if escalation is used in flexible notifications
Date Apr 30, 2021
Checkmk Editon Checkmk Raw (CRE)
Checkmk Version 2.1.0i1 2.0.0p4
Level Trivial Change
Class Bug Fix
Compatibility Compatible - no manual interaction needed

If flexible notifications with option "Restrict to nth to mth notification (escalation)" were used, notifications failed with an AssertionError in notify.log.

To the list of all Werks