Catch up on the latest product updates, best practices, and expert insights from the Checkmk Conference #12 – Watch the livestream recordings now

Werk #13973: Putting a service into downtime no longer requires access to the corresponding host in the REST API

Component REST API
Title Putting a service into downtime no longer requires access to the corresponding host in the REST API
Date Feb 17, 2023
Level Trivial Change
Class Bug Fix
Compatibility Compatible - no manual interaction needed
Checkmk versions & editions
2.3.0b1 Checkmk Community, Checkmk Pro, Checkmk Ultimate, Checkmk Ultimate MT
2.2.0b1 Checkmk Community, Checkmk Pro, Checkmk Ultimate, Checkmk Ultimate MT
2.1.0p23 Checkmk Community, Checkmk Pro, Checkmk Ultimate MT

Putting a service into downtime using the REST API required permissions to access the corresponding host in the REST API. The REST API call would fail with an error message stating that,

Host 'myhost' exists, but is not monitored. Activate the configuration?

This behaviour doesn't match the GUI's and is now no longer the case.

To the list of all Werks