Werk #14293: Enforce use of new apache hooks before updating to 2.2

Component Site management
Title Enforce use of new apache hooks before updating to 2.2
Date Sep 5, 2022
Checkmk Editon Checkmk Raw (CRE)
Checkmk Version 2.2.0i1
Level Trivial Change
Class Bug Fix
Compatibility Compatible - no manual interaction needed

With #14281 a new system apache configuration hook for managing the system apache reverse proxy config has been introduced.

In all previous versions the transition was highly recommended for security reasons, but not enforced to stay compatible. As of Checkmk 2.2 the new mechanism will be enforced.

If you try to update an existing site to 2.2 which has not been switched to the new mechanism with omd update-apache-config [SITE], then the update will be aborted.

To the list of all Werks