Werk #14320: Fix KeyError on mknotifyd start after upgrade to 2.1.0

Component Notifications
Title Fix KeyError on mknotifyd start after upgrade to 2.1.0
Date May 24, 2022
Checkmk Editon Checkmk Enterprise (CEE)
Checkmk Version 2.1.0p1 2.2.0i1
Level Trivial Change
Class Bug Fix
Compatibility Compatible - no manual interaction needed

If the notification spooler was used on a remote site, after upgrade to 2.1.0 the start of the mknotifyd could fail with the error "KeyError: 'encryption'".

To the list of all Werks