Werk #14330: Fix possible ValueError on dashboards after update to 2.1

Komponente User interface
Titel Fix possible ValueError on dashboards after update to 2.1
Datum 10.06.2022
Checkmk-Editon Checkmk Raw (CRE)
Checkmk-Version 2.1.0p3 2.2.0i1
Level Kleine Änderung
Klasse Bugfix
Kompatibilität Kompatibel - benötigt kein manuelles Eingreifen

If dashboards were created with a custom topic in version 2.0, the error "ValueError (invalid literal for int() with base 10: '')" could occur after updating to 2.1.

Possible workaround was to change the topic of the affected dashboard to a builtin topic and run "cmk-update-config" as site user again. The dashboard should be ok after that and you can change back to the custom topic.

Zur Liste aller Werks