We use cookies to ensure that we give you the best experience on our website. Visit our Privacy Policy to learn more. If you continue to use this site, we will assume that you are okay with it.

Your choices regarding cookies on this site.
Your preferences have been updated.
In order for the changes to take effect completely please clear your browser cookies and cache. Then reload the page.

Werk #6341: Fixed 'SyntaxError: invalid syntax' warning when installing bakery packages on older systems

ComponentAgent Bakery
TitleFixed "SyntaxError: invalid syntax" warning when installing bakery packages on older systems
Date2018-07-10 12:34:30
Checkmk EditionCheckmk Enterprise Edition (CEE)
Checkmk Version1.4.0p35,1.6.0b1,1.5.0b9
LevelTrivial Change
ClassBug Fix
CompatibilityCompatible - no manual interaction needed

When installing agent bakery RPMs/DEBs an error message "SyntaxError: invalid syntax" could occur. This was caused by a pre-install script that should warn about incompatible Python versions. This script was incompatible to older Python versions, like Python 2.4.

At least in case of the RPMs the installation did complete despite of this message.