Download Archive

Outdated versions of the Checkmk Raw Edition (CRE) and Checkmk Enterprise Free Edition (CFE) can be found here. Please select the package appropriate to your Linux distribution.
If the version you are looking for is not listed here, please send a request to feedback@checkmk.com with your OS, the required version and the reason why you need that version.

The archive for the Checkmk Enterprise Editions can be found in the customer portal.

2.0.0p11
09/16/2021
2.0.0b1
12/01/2020
Note: Please keep in mind that a downgrade of Checkmk 1.6 to older versions is not possible. As of firmware version 1.4.0 you need the 1.4+ package of Checkmk. For appliances with older firmware versions, please use the <1.4 package.
1.6.0p25
08/04/2021
1.6.0p24
05/03/2021
1.6.0p22
02/24/2021
1.6.0p21
02/16/2021
We have discovered an issue with NagVis in this release which may lead to broken map configuration files that need to be repaired manually. A fix has already been developed and will be released soon.
1.6.0p19
11/17/2020
1.6.0p18
10/13/2020
As of firmware version 1.4.0 you need the 1.4+ package of Checkmk. For appliances with older firmware versions, please use the <1.4 package.
1.5.0p25
08/19/2020
1.5.0p24
01/16/2020
1.5.0p23
10/28/2019
1.5.0p22
09/09/2019
1.5.0p21
07/31/2019
As of firmware version 1.4.0 you need the 1.4+ package of Checkmk. For appliances with older firmware versions, please use the <1.4 package.
1.4.0p38
01/29/2019
1.4.0p37
10/19/2018
As of firmware version 1.3.0 you need the 64-bit package of Checkmk. For appliances with older firmware versions, please use the 32-bit package. As of firmware version 1.4.0 you need the 1.4+ package of Checkmk. For appliances with older firmware versions, please use the <1.4 package.
1.2.8p27
08/05/2020
1.4.8
04/03/2020
Important: If you want to update to this version, you have to install at least version 1.3.7 before. This version is not compatible with the Checkmk rail1.
1.4.0
04/10/2018
Important: If you want to update to this version, you have to install at least version 1.3.7 before. This version is not compatible with the Checkmk rail1.
1.3.20
04/05/2018
Important: If you want to update to this version, you have to install at least version 1.3.7 before. This version is not compatible with the Checkmk rail1.
1.3.11
02/09/2017
Important: If you want to update to this version, you have to install at least version 1.3.7 before. This version is not compatible with the Checkmk rail1.
1.3.7
09/08/2016
Important: If you want to update to this version, you have to install at least version 1.2.1 before. This version is not compatible with the Checkmk rail1.